Part numbers starting with RFC
19 part numbers start with RFC. Open any part to request a quote.
19 part numbers
- RFC-010RcsRCS Audio-Systems RFC-010 19 rack" Flight Case , 10U
- RFC-012RcsRCS Audio-Systems RFC-012 48,3 cm ( 19 inch )Rack 'flight case' (12U) 48,3 cm ( 19 inch
- RFC-015RcsRCS Audio-Systems RFC-015 19 rack" Flight Case , 15 U
- RFC-020RcsRCS Audio-Systems RFC-020 19 rack" Flight Case , 20 U
- RFC02500MD531P102MTSMTS MAGNETOSTRICTIVE, ABSOLUTE, NON-CONTACT LINEAR-POSITION SENSOR, R-SERIES, FLEXIBLE
- RFC02MM2STRROHMROHM Diode, 500mA 200V, 2-Pin SOD-123FL RFC02MM2STR
- RFC2-10SIMORFC2-10S IMO
- RFC2-16IMORFC2-16 IMO
- RFC2-32IMORFC2-32 IMO
- RFC2-6IMORFC2-6 IMO
- RFC3-10SIMORFI FILTER FOR EMC COMPLIANCE 1PHASE, 200V, 10AMP CATEGORY C3 by IMO
- RFC3-3SIMORFI FILTER FOR EMC COMPLIANCE 1PHASE, 200V, 3AMP CATEGORY C3 by IMO
- RFC3-6IMORFI FILTER FOR EMC COMPLIANCE 3PHASE, 400V, 6AMP CATEGORY C3 by IMO
- RFC-4801-636-121-202NovotechnikANGULAR POSTION SENSOR, 0 TO 360° ANGLE RANGE, 24V, 4-20MA, 1M CABLE, SHIELDED by
- RFC4853-607-111-501NovotechnikROTARY SENSOR, 0-70° MIN. MEASURING RANGE, 24V, M12 CONNECTOR 4-PIN, WITH CABLE by
- RFC4853-636-111-202NovotechnikROTARY HALL TOUCHLESS SENSOR, 360 DEG, 24VDC, 1 CHANNEL, 4 POLE 1M CABLE
- RFC-4853-636-121-202NovotechnikNovotechnik RFC-4800 Series Hall Effect Position Sensor, 1024ppr ppr, Current Signal
- RFC-4853-636-121-501Novotechnik RFC-4800 Series Hall Effect Position Sensor, 1024ppr ppr, Analogue Signal
- RFCSKT1EatonNRX CELL SWITCH KIT, 1 FROM C CONTACT PER POSITION by Eaton
